Document preview not functioning properly
Incident Report for MCN Healthcare
Resolved
The issue has fully been resolved. We understand the inconvenience these types of incidents can cause. Internal processes are in place to fully investigate, and take any and all necessary measures to prevent future occurrences. Thank you for your patience and understanding.
Posted May 13, 2020 - 11:42 MDT
Monitoring
We have implemented a solution to the issue and are currently monitoring our services to ensure a successful recovery. You are welcome to return to your normal activities. We will provide another update once we have confirmed the resolution.
Posted May 07, 2020 - 11:48 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 06, 2020 - 12:17 MDT
Identified
We have identified an issue preventing document preview from functioning.
Posted May 06, 2020 - 12:16 MDT
This incident affected: Policy Manager.