Investigating 500 Error When Visiting Policy Manager
Incident Report for MCN Healthcare
Resolved
The issue has fully been resolved. We understand the inconvenience these types of incidents can cause. Internal processes are in place to fully investigate, and take any and all necessary measures to prevent future occurrences. Thank you for your patience and understanding.
Posted Feb 22, 2024 - 06:05 MST
Investigating
We are currently investigating an issue that may be affecting your ability to successfully use MCN products and services. Once we have more information we will provide an update.
Posted Feb 22, 2024 - 05:38 MST
This incident affected: Policy Manager, Policy Library, and Contract Manager.