Unable to access Policy Manager

Incident Report for MCN Solutions

Resolved

The issue has fully been resolved. We understand the inconvenience these types of incidents can cause. Internal processes are in place to fully investigate, and take any and all necessary measures to prevent future occurrences. Thank you for your patience and understanding.
Posted Feb 19, 2026 - 08:46 MST

Update

We are continuing to monitor for any further issues.
Posted Feb 17, 2026 - 17:25 MST

Monitoring

We have implemented a solution to the issue and are currently monitoring our services to ensure a successful recovery. You are welcome to return to you normal activities. We will provide another update once we have confirmed resolution.
Posted Feb 17, 2026 - 15:20 MST

Update

We are currently working with our hosting service provider to further investigate this issue. In the meantime, we are deploying temporary resources as an attempt to restore services while we strive for a permanent resolution.
Posted Feb 17, 2026 - 13:34 MST

Update

We have narrowed the issue down to the SSO (Single Sign On) service and have deployed further logging to isolate the root cause. We will continue providing updates as we diligently work towards resolution.
Posted Feb 17, 2026 - 10:56 MST

Investigating

We are currently experiencing an unexpected interruption in service that is preventing users from accessing Policy Manager. We are diligently working on this issue and will continue providing updates until we reach resolution. In the meantime, if you need to access a policy, please reach out to your Administrator. The system backup files that include your policies should still be accessible by your organization.
Posted Feb 17, 2026 - 07:45 MST
This incident affected: Policy Manager, Policy Library, and Contract Manager.