Identified Amazon Web Services (AWS) Disruptions.
Incident Report for MCN Healthcare
Resolved
The issue with AWS has been resolved and the service is operating normally.

We understand the inconvenience these types of incidents can cause.

Thank you for your patience and understanding.
Posted Aug 31, 2021 - 17:49 MDT
Monitoring
AWS is beginning to see signs of recovery and continues to work toward full resolution.

You are welcome to return to your normal activities. We will provide another update once we have confirmed resolution.
Posted Aug 31, 2021 - 16:39 MDT
Identified
Amazon Web Services (AWS) has identified issues with their Amazon Load Balancing and AWS Internet Connectivity.

This may cause you to experience slowness or connection issues that may result in error messages. Amazon is aware and diligently working towards a resolution

We will continue providing updates until there is a resolution. You may also view AWS Status Page at this link: https://status.aws.amazon.com/
Posted Aug 31, 2021 - 14:46 MDT
This incident affected: Policy Manager and Contract Manager.