Unable to access StayAlert!
Incident Report for MCN Healthcare
Resolved
The issue has fully been resolved. You may access your StayAlert! account. We understand the inconvenience these types of incidents can cause. Internal processes are in place to fully investigate, and take any and all necessary measures to prevent future occurrences. Thank you for your patience and understanding.
Posted Jun 02, 2022 - 15:49 MDT
Identified
We are currently experiencing an unexpected interruption in service that is preventing users from accessing StayAlert!. We are diligently working on this issue and will continue providing updates until we reach a resolution.
Posted Jun 02, 2022 - 14:26 MDT
This incident affected: StayAlert!.