500 Errors & Webpages having formatting issues
Incident Report for MCN Healthcare
Resolved
The issue has been resolved. We understand the inconvenience these types of incidents can cause. Internal processes are in place to fully investigate, and take any and all necessary measures to prevent future occurrences. Thank you for your patience and understanding.
Posted Mar 11, 2024 - 10:57 MDT
Update
At this time we are noticing stability throughout the day, we will continue to monitor our services as we work towards a long-term solution. We will continue to provide updates once we have confirmed the resolution.
Posted Feb 23, 2024 - 15:23 MST
Monitoring
We have implemented a solution to the issue and are currently monitoring our services to ensure a successful recovery. You are welcome to return to your normal activities. We will provide another update once we have confirmed the resolution.
Posted Feb 22, 2024 - 15:00 MST
This incident affected: Policy Manager, Policy Library, and Contract Manager.